-
mysqldump导出导入所有库、某些库、某些表的示例
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
mysqldump导出导入所有库、某些库、某些表的例子: 1 导出所有库 mysqldump -uusername -ppassword --all-databases all.sql 2 导入所有库 mysqlsource all.sql; 3 导出某些库 mysqldump -uusername -ppassword --databases db1 db2 db1db2.sql 4 导入某些库[详细]
-
MySQL Binlog三种格式介绍及剖析
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
MySQL Binlog三种格式介绍及剖析: 一.Mysql Binlog格式介绍 MySQL binlog日志有三种格式,分别为Statement,MiXED,以及ROW! 1.Statement:每一条会修改数据的sql都会记录在binlog中。 优点:不需要记录每一行的变化,减少了binlog日志量,节约了IO,提高性[详细]
-
mysql及事务
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
什么是事务 事务是作为一个逻辑单元执行的一系列操作,一个逻辑工作单元必须有四个属性,称为 ACID(原子性、一致性、隔离性和持久性)属性,只有这样才能成为一个事务 一、事务的特性(ACID) 原子性(Atomicity) 一组操作要么全成功,要么全失败。 一致性[详细]
-
MYSQL RC 和RR隔离级别差别性
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
今天一个朋友咨询我关于MYSQL 的LOCK,我针对他的问题,整理了一篇BLOG,供大家了解学习,有兴趣的同学可以参考来测试加深原理的理解。 结论: 1.RR隔离级别并发性没有RC好 2、开发过程中,事务要尽量小,结束要快 3、需要创建合适的索引来减少全表扫的概率[详细]
-
MySQL DDL详情揭示
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
MySQL中DDL语句,即数据定义语言,用于创建、删除、修改、库或表结构,对数据库或表的结构操作。常见的有create,alter,drop等。这类语句通常会耗费很大代价,特别是对于大表做表结构变更。本篇文章会揭露各类DDL语句执行的详细情况。 1.Online DDL简介 在M[详细]
-
linux下apache+mysql+php开发环境纯源代码编辑搭建
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
linux下apache+mysql+php开发环境纯源代码编译搭建(转)[@more@] 记录一下我在fedora core 1下通过源代码编译出来的apache+mysql+php开发环境的全部过程 通常安装一台服务器当然使用rpm是最方便的,不需要考虑太多配置的问题,就可以轻松获得需要的环境了。不[详细]
-
innodb_data_file_path和innodb_data_home_dir
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
今天研究下关于mysql数据的相关参数以及innodb引擎下的共享表空间和独立表空间介绍,参数主要包括innodb_data_file_path、innodb_data_home_dir、innodb_buffer_pool_size、innodb_buffer_pool_instances四个参数。 一:首先介绍innodb_buffer_pool_size 我[详细]
-
MySQL 多表更新的限制
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
在对多表进行更新时,不支持ORDER BY、LIMIT。 mysql update Subscribers2 s,tmp_Subscribers_01 t set s.date=2015-01-01, - s.LastAccessTimeStamp=unix_timestamp(date 2015-01-01) - where s.MSISDN=t.MSISDN and t.id between 1 and 5000 limit 2000; E[详细]
-
mysql can t start dues to the disk space is full
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
use ./mysqld_safe --user=mysql start mysql. The mysql can not start. There are much mysql restart info show on the screen always. And can not find the /var/lib/mysql/mysql.sock file. The reason: Then find the space is full. So the mysql ca[详细]
-
global_buffers优化
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
对于global_buffers,可以理解为Oracle的SGA,用于在内存中缓存从数据文件中检索出来的数据块,可以大大提高查询和更新数据的性能,主要包括以下几个参数组成。 1、innodb_buffer_pool_size 这个参数是InnoDB存储引擎的核心参数,默认为128MB,这个参数注意[详细]
-
MySQL 5.7 performance_schema库和sys库常用SQL
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
performance_schema库常用SQL: 查看没有主键的表: SELECT DISTINCT t.table_schema, t.table_name FROM information_schema.tables AS t LEFT JOIN information_schema.columns AS c ON t.table_schema = c.table_schema AND t.table_name = c.table_name A[详细]
-
Linux环境MySQL5.6安装实践
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
MySQL的安装相对于Oracle来说非常简单,个人觉得与TimesTen的安装配置更为接近,而且后面的Master-Slave或Master-Master集群配置更为简单,甚至比TimesTen的ASP/Active-Active/Active-Standby配置都比TimesTen还要简单,不过MySQL涉及的初始化参数还是比较多[详细]
-
如何绘制生产管理流程图,教你快速绘制流程图
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
生产管理又称生产控制,是指对企业整个生产系统设置和运行进行各种管理的工作。以往工作中,我们花费大量时间写生产管理流程介绍,还要确保各个环节是否有重复和多于事项。随着科技发展,各种管理软件可以轻松帮助企业实现自动化办公。尤其是在企业生产过程[详细]
-
怎样通过以太网远程访问PLC 较简单的方法
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
一般的 PLC设备 数据通讯 在条件允许的情况下 都采用有线的方式进行,如果 PLC设备距离中控室 距离较 远 , 那布线就相当 麻烦,为 了 解决这个问题, 我们推荐 采用新的 组网 方案: 使用零遁 的 4 G 智能网关 可以远程实现 plc与电脑编程软件 、 与电脑组[详细]
-
mysql,出现同步停止的错误的处理
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
因 Duplicate entry 或 非正常关闭mysql, 出现同步停止的错误时,可执行下列命令跳过错误log,从错误log下一条继续同步: mysql SET GLOBAL SQL_SLAVE_SKIP_COUNTER=1; mysql slave start; 非正常关闭mysql而导致的错误log 应该不会太多(有次我手动恢复了8条左[详细]
-
MySQL使用pt-archiver归档历史数据
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
pt-archiver可以将表按照指定条件归档到历史数据库中,也支持文件导出,对于归档清理线上历史数据非常方便。 如果要归档表的数据到历史数据库的表中,需要预先在历史数据库中创建表结构。 (1) 按照条件归档表中的历史数据到历史数据中,同时在本地生成归档文[详细]
-
MySQL级联复制的同步难题
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
今天碰到一个有些奇怪的问题,有一套环境,在主从复制的时候有一些问题。 大体的流程设计如下: 三个节点位于三个不同的区域,因为节点1和节点3之间的网络存在问题,所以走了节点2来中转,由此可见延迟是难免的,但是延迟不能太大。最终的数据还是要通过节点[详细]
-
mysql innodb cluster 创建
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
环境准备: 1 下载和安装需要的软件(本人的软件版本--都是mysql Community中的Linux Generic版本) mysql-server(mysql-8.0.17-linux-glibc2.12-x86_64.tar.xz) mysql-router(mysql-router-8.0.17-linux-glibc2.12-x86_64.tar.xz) mysql-shell(mysql-shell-8.0[详细]
-
MySQL DDL详情揭秘
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
MySQL中DDL语句,即数据定义语言,用于创建、删除、修改、库或表结构,对数据库或表的结构操作。常见的有create,alter,drop等。这类语句通常会耗费很大代价,特别是对于大表做表结构变更。本篇文章会揭露各类DDL语句执行的详细情况。 1.Online DDL简介 在M[详细]
-
InnoDB之Dirty Page、Redo log
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
在InnoDB中,buffer pool里面的dirty page一方面可以加快数据处理速度,同时也会造成数据的不一致(RAM vs DISK)。本文介绍了dirty page是如何产生,以及InnoDB如何利用redo log如何消除dirty page产生的数据不一致。 当事务(Transaction)需要修改某条记录(r[详细]
-
DBeaver5.0.5链接mysql
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
DBeaver5.0.5链接mysql: 1.下载JDK,并安装。 2.配置JDK环境变量。 3.下载好dbeave5.0.5,点击dbeaver.exe。 4. 新建链接---选择mysql--- 5.编辑网络,用户名、密码 6.测试链接 注意:SSH,SOCKS代理,SSL不用配置 小提示:如果在IP网络互通,且可以用crt链[详细]
-
MySQL内存占用计算公式
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
MySQL最大可使用内存(M): select (@@key_buffer_size +@@innodb_buffer_pool_size + @@tmp_table_size + @@max_connections*(@@read_buffer_size + @@read_rnd_buffer_size + @@sort_buffer_size + @@join_buffer_size + @@binlog_cache_size + @@thread_[详细]
-
浅谈怎样在UNIX系统下安装MySQL数据库
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
浅谈怎样在UNIX系统下安装MySQL数据库(转)[@more@] CODE: # cd /usr/src # tar -zvxf mysql-3.22.25-pc-linux-gnu-i686.tar.gz (产生 mysql-3.22.25-pc-linux-gnu-i686目录) # cd mysql-3.22.25-pc-linux-gnu-i686 # ./configure --prefix=/usr/local/mysql[详细]
-
mysql解压版运行
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
mysql解压版运行: 1.初始化mysql 解压完后打开命令行(cmd)进入mysql的bin目录输入初始化mysql命令: mysqld --initialize-insecure 2.添加环境变量 复制bin目录如:D:mysql-5.7.21-winx64bin 计算机--属性--高级系统设置--环境变量--系统变量--变量(Pa[详细]
-
pt-table-checksum出现的问题
所属栏目:[MySql教程] 日期:2022-04-04 来源:DaWei
今天使用pt-table-checksum检查数据库的一致性, 突然报下面的错误:一脸懵逼,这个语句在其他机器上执行都没问题 检查语句如下:pt-table-checksum h=xx,u=xx,p=xxx,P=xx --databases=xx 报错如下: Cannot connect to MySQL because the Perl DBD::mysql mo[详细]

