-
Mysql 5.5 数据库开启关闭命令
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
启动MySQL服务 ./bin/mysqld_safe --defaults-file=/etc/my.cnf [1] 21698 [root@localhost bin]# 160402 05:57:36 mysqld_safe Logging to /log/err.log. 160402 05:57:36 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql error日[详细]
-
mysql.gtid_executed表Previous gtid Event的更改
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
之所以把mysql.gtid_executed表的作用和Previous gtid Event的改变放到一起进行描述是因为它们后面文章探讨的基[详细]
-
官方压测工具mysqlslap介绍及利用
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
mysqlslap是官方的一款做压力测试的工具,可以模拟多个客户端进行并发测试。 比如可以模拟多少并发,执行多少次,针对某个存储引擎等等 比如对myisam引擎做并发量为100,查询次数为1000 --concurrency用于指定并发量,--number-of-queries=1000用于指定查询[详细]
-
随笔 MySQL setup_instruments中关于部分信息不能更换
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
朋友告诉我如下操作不能修改: mysql update setup_instruments set enabled=no where name=memory/performance_schema/table_handles; Query OK, 1 row affected (2.61 sec) Rows matched: 1 Changed: 1 Warnings: 0 mysql select * from setup_instruments[详细]
-
关于修测验UTO_INCREMENT列的默认值的测试
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
其实是个很简单的操作,但是忽然有人问我就是想不起来,暂且做个笔记在这里。 mysql create table test2(id int(2) AUTO_INCREMENT,name varchar(10),primary key(id)); Query OK, 0 rows affected (0.03 sec) mysql insert into test2 values(null,a),(null[详细]
-
mysql 多个参数选项文件my cnf优先级研发
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
my.cnf是mysql服务器在unix平台下默认的配置文件的文件名。 输入my_print_defaults可以得出mysql server启动时所读取的my.cnf的顺序:(一般为该四个,根据安装方式、OS发行版、mysql版本而定) 或者 $ mysql --help | grep my.cnf /etc/my.cnf /etc/mysql/m[详细]
-
MySQL 如何迅速的查视Innodb数据文件
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
经常有朋友问我一些如何查看Innodb数据文件的问题比如: 如果我是UTF8字符集,如果插入字符a到底占用几个字节 ? 主键和普通索引叶子节点的行数据在存储上有哪些区别? 如何证明rowid的存在? 数据中的NULL值如何存储的? char和varchar在存储上的区别? 如[详细]
-
mysql 5.5信息--innodb_read write _io_threads
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
# 在5.1版本上,这FILE_IO这一块MYSQL只用了4个线程来处理IO; # 但在5.5上,随着对多线程的更强支持;INNODB也加强了对IO读写线程的支持;更多发挥多线程的优势 ; # IO线程默认增加到了10个;(配太多也没用,因为IO能力有限,需要配合特殊机型) # 其实这[详细]
-
建表和sql不规范 导致 服务器几乎无反应
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
建表和sql不规范 导致 服务器几乎没反应 问题描述: 1)研发人员说测试库session满了,请求调大最大连接数。 数据库中发现大量(1944个)的session,语句基本相同,SELECT * FROM ali_phone_info where phone=13004669173 , 处于sending data状态。 服务器连s[详细]
-
更换mysql时区
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
需要查看mysql的当前时区,用time_zone参数 mysql show global variables like %zone%; +------------------+--------+ | Variable_name | Value | +------------------+--------+ | system_time_zone | CST | ---系统时间,北京时间 | time_zone | SYSTEM |[详细]
-
MySQL5.7 JSON类型列创建索引查询一例
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
创建json类型的表test: mysql CREATE TABLE test(data JSON); Query OK, 0 rows affected (0.47 sec) mysql insert into test values({name:abc,sex:nan,area:[1,2]}); Query OK, 1 row affected (0.39 sec) mysql insert into test values({name:abc,sex:na[详细]
-
MySQL 数据库和表操作
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
-- 创建数据库 -- 创建 classroom 数据库 create database 数据库名 default character set 字符编码 collate 排序规则; eg: create database classroom default character set utf8 collate utf8_general_ci; -- 查看所有数据库 show databases; -- 选择数[详细]
-
MySQL 一个简单insert语句的大概流程
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
简单记录,可能有误,主要记录重要的接口以备后用。 一、操作说明 我建了一个简单的表,插入一个简单的数据。 Query OK, 0 rows affected (2.38 sec) mysql insert into testin values(10); Query OK, 1 row affected (0.02 sec) 主要跟踪这个简单的插入语句[详细]
-
MySQL 8.0新特性-不可见索引
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
MySQL支持不可见索引,即优化器不会使用该索引。 不可见索引特性不可以用于主键。 默认索引是可见的。可以在create table、create index、alter table操作中使用关键字visible、invisible来指定索引是否可见。 create table t1 ( i int, j int, k int, index[详细]
-
从MySQL得到最大的性能
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
优化是一项复杂的任务,因为它最终需要对整个系统的理解。当用你的系统/应用的小知识做一些局部优化是可能的时候,你越想让你的系统更优化,你必须知道它也越多。 因此,本章将试图解释并给出优化MySQL的不同方法的一些例子。但是记住总是有某些(逐渐变难)是[详细]
-
浅谈MySQL中的事务隔离级别
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
之前写了一篇浅谈事务(一),算是对事务的一个基本认识,今天来简单总结一下事务的隔离级别,虽然是老掉牙的知识点,重温一下还是值得的。 在MySQL中基本有这两种事务隔离级别的设置,默认的RR(Repeatable-Read)和实际中常见的RC(Read-Committed)。两者区[详细]
-
MySQL主从同步报error 1236
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
【一】前言:作为MySQL的数据库管理员经常会碰到主从同步的问题,比较常见的有error 1236的报错。刚好最近又碰到了这个报错,以下是整理的文档; 【二】问题说明 1、环境信息 mysql 版本:5.7.20 操作系统版本:centeros 6.5 2、报错信息 点击(此处)折叠或打[详细]
-
MySQL执行计划EXPLAIN详解
所属栏目:[MySql教程] 日期:2022-04-06 来源:DaWei
本文以MySQL 5.7 Reference Manual为主轴(翻译取其精华)并结合网文百家之长整理而成,因为笔者水平有限,文中如有不准确之处请包涵,如转载请注明原文出处guocun09-Oraman的日记 基本概念: EXPLAIN 提供SQL语句是怎么样执行的信息,为select,delete,insert,[详细]
-
浅析mysql中各种表空间 tablespaces 的概念
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
mysql中,会涉及到各种表空间的概念,虽然,很多方面这些概念和Oracle有相似性,但也有很多不同的地方,初学者很容易被这些概念弄的晕头转向,从而,混淆这些概念的区别和理解,下面,就简要介绍和说明一下这些表空间的概念。 1.系统表空间(System Tablespa[详细]
-
秒回--mysqlbinlog flashback 5.6版本
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
DBA或者开发人员,有时会误删除或者误更新数据。传统的数据库恢复方法是利用之前的备份再加上误操作之前的binlog,来恢复数据。该方法需要耗费较长时间来恢复备份,甚至需要停机维护,严重降低系统的可用性。 MySQL的flashback功能是由淘宝的彭立勋,在MySQL[详细]
-
Semi_Sync Replication方案的复制
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
基于传统的复制,可能存在从库复制延迟的问题,那么master宕机后,如果此时master不能恢复,只能用slave代替master,slave处于落后的状态,就会导致数据丢失。可以通过半同步复制解决部分问题。 参数rpl_semi_sync_master_wait_point在MySQL的半同步复制中,[详细]
-
Linux平台下MySQL数据库定时储存
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
根据要求写下MySQL备份脚本,要求如下:对指定数据库进行日备份并且将备份文件保存一周,对一周以外文件自动删除。 1、创建shell脚本 [root@server18 mysql]$ mkdir -p /home/mysql/DB_BAK/day_bak/ [root@server18 mysql]$ vim day_bak.sh DB_NAME=tdc_ntt_[详细]
-
MySQL 5.7 MGR单主确定主节点方式
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
我们行MGR年底要上线了,每天都要看官方文档学习,做测试,坚持每天写一个小知识点,有想一起学习的么~ MySQL 5.7 MGR单主确定主节点是哪个,我们可以通过成员ID来判断,然后结合read_only参数来确认。 [root@localhost ~]# mysql -uroot -p -P 3306 -h 127.[详细]
-
mysql 数据输入redis缓存
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
假设表结构如下 CREATE TABLE sas_sys_app ( user_id varchar(38) DEFAULT NULL, app_id int(11) DEFAULT NULL ) ENGINE=InnoDB DEFAULT CHARSET=utf8 编写sql文件 SELECT CONCAT( *4rn, $, LENGTH(redis_cmd), rn, redis_cmd, rn, $, LENGTH(redis_ke[详细]
-
对Mysql中的read_only 只读属性做简要解说
所属栏目:[MySql教程] 日期:2022-04-05 来源:DaWei
对于MySQL单实例数据库和master库,如果需要设置为只读状态,需要进行如下操作和设置: 将MySQL设置为只读状态的命令: mysql show global variables like %read_only%; mysql flush tables with read lock; mysql set global read_only=1; mysql show global[详细]

